Engage is experiencing email campaign editor saving issues for some users

Incident Report for Olo Engage

Resolved

All email campaigns / templates issues are now resolved.
Posted Mar 10, 2025 - 12:46 EDT

Monitoring

A fix has been implemented by our partner and we are monitoring the results.
Posted Mar 10, 2025 - 12:37 EDT

Identified

We’ve identifier an ongoing issue with one of our partners used for our email campaigns.
We are seeing less errors at this time, but still investigating.
Posted Mar 10, 2025 - 12:13 EDT

Investigating

Olo | Engage is currently experiencing an intermittent interruption in service and some users are unable to save or edit email campaigns. Our Engineers are currently investigating and we will continue to provide frequent updates until resolved.
Posted Mar 10, 2025 - 12:07 EDT
This incident affected: Wisely Dashboard (Web).